[Front] [Previous Chapter] [Next Chapter]

Introduction to DOSBook

Overview

This chapter describes the main structure of DOSBook. The structure is the key to its hypertext nature and is important for you to understand when customizing or translating DOSBook.

DOSBook is an online hypertext manual. It is built from the DR-DOS User Guide document files which have been produced using FrameMaker.

Information can be found easily within DOSBook by using the search option, table of contents, or index. You can click on highlighted words or phrases to go to other sections of information or to see short glossary notes as pop-ups.

DOSBook Physical File Structure.

The compiler that produces the DOSBook database takes a file that has the extension .PUB as its input. The publication (.PUB) file contains a list of chapter files which have the extension .CHP. The chapter files contain information about the text files which usually have the extension .DOC or .TXT. The text in DOSBook is contained in ASCII format text files.

There is also a file with the extension .HOH (help on help) that contains the text explaining how to use DOSBook. This file is not part of the publication file but is read as part of the input to the compiler by means of a switch. You access this information in DOSBook by pressing the hot key <F1>, or by selecting Help for DOSBook from the Help menu.

DOSBook Logical File Structure

There is a logical structure to the files that make up DOSBook. This structure is reflected in the order that the files are placed in the publication file (DRDOS.PUB.) This structure is as follows:

The Welcome Screen

The welcome screen is the first screen you see after typing DOSBOOK at the system prompt. It presents you with a list of sections to choose from.

Highlight one of the sections by using the <Tab> key or your mouse. Press <Enter> or double-click the left mouse button to select the section.

The file WELCOME.TXT contains the text for the welcome screen. This is the first file listed in the publication (.PUB) file.

The .HOH file

The .HOH file contains the help text which explains how to use DOSBook. You can access this from the welcome screen, or at any point in DOSBook, by pressing the <F1> key. For the English version of DOSBook, this file is called DOSBOOK.HOH. The compiler needs to know what name is used for this file.

The Table of Contents

There is a complete table of contents that covers everything in DOSBook. The contents are ordered by the chapter order in the publication file and by the order in which the headings appear in the text.

The table of contents is generated by the compiler and consists of all the paragraphs that are tagged as @Head1, @Head2, @Head3, and @Head3A. The table of contents is accessed by selecting ``Contents'' from the welcome screen. You can access the complete table of contents at any point in DOSBook by pressing <Alt> C, which will leave you in the table of contents at the section you were previously reading.

There are references to produce the links from the table of contents on the welcome page to the relevant text in the database. The references have the following form:

__NEWCONT_nn

where nn is a number from 00 to 10.

Chapters of DOSBook

The information available in DOSBook is currently divided into chapters which make up the DR-DOS User Guide. These are contained in text files that are logically structured. The text is separated into many text files because it is easier to handle smaller files of text.

The text within a text file is structured into paragraphs. There are different types of paragraphs including headings, body text and commands. You must must place a blank line between paragraphs in the text editor.

All paragraphs in the DOSBook text files are marked by tags. A tag is a list of text and format attributes associated with the paragraph. The tags are used to structure the text to form DOSBook.

Paragraphs are grouped together in sections. A section is begun by a paragraph tagged as @Head1, @Head2, @Head3, @Head3A, @Head4, or @Head5 and is ended by the next one of these heading paragraphs, or by the end of the current text file.

The Index

The index is automatically generated by the compiler that builds the DOSBook database. Index entries placed in the text are used to make up the entire index, which is alphabetically sorted.

The index provides another way, other than links in the text, of linking different sections of text. Index entries are alphabetically sorted and displayed. You access the index in DOSBook by pressing <Alt> I. You can find the subject you need, and select the word or phrase to be taken to that section.

The index entries appear in the following form when using an ASCII text editor.

<$Iprimary entry>

or

<$Iprimary entry;secondary entry>

The Glossary

The glossary is the last file listed in the publication (.PUB) file. It contains short definitions of keywords or phrases. One of these definitions appears as a pop-up when you select that particular keyword or phrase in a section of text.

Pop-ups are described in more detail in the section ``Pop-ups and Links,'' in Chapter 2.

Pressing <Alt> G in DOSBook displays a list of all the glossary headings. This is a contents for the glossary and allows you to access the information in the glossary directly as well as through the pop-up references.

Each definition in the glossary is preceded by a paragraph that contains the keyword or phrase and is tagged as a @Head3 paragraph. A special tag is used at the beginning of the glossary section to show that all the headings under this are glossary headings. The glossary tag looks like the following:

@GLOSSARY =

Menus

Three pull-down menus are provided in DOSBook. They are described in the following tables.

Table 1-1 Window Menu
OptionWhat it does
Resize Window (Alt F5)Enlarges or decreases the size of the window. (This menu option is only available when DOSBook is opened from within EDIT.)
Print sectionDisplays a dialog box that gives you the option to print the currently displayed section of text or the complete chapter to LPT1 or specify a filename. if you specify a filename, the text is saved to that file. Instead of a filename, the text is saved to that file. Instead of a filename, you can specify an output device, such as LPT2.
ExitExits DOSBook.
Table 1-2 Search Menu
OptionWhat it does
Search indexEnables you to search for a topic in the index. You are taken to that entry in the index if a match is found.
Search textEnables you to search for a word in the text.
Repeat last search F3Repeats the search you have just completed enabling you to find another topic in the index, or the next occurrence of the word in the text. This option is only available after you have completed a search.
Table 1-3 Help Menu
OptionWhat it does
Help for DOSBook (F1)Displays the help text about how to use DOSBook.
Contents (Alt C)Displays the table of contents.
Glossary (Alt G)Displays the glossary section.
Index (Alt I)Displays the index
Backtrack (Alt B)Backtracks through the previous pages you have viewed. Repeated use of this button enables you to trace back through the screens you have viewed.
Next (Alt N)Goes to the next page.
Previous (Alt P)Goes to the page that precedes the current page.
About...Displays copyright information.


[Front] [Previous Chapter] [Next Chapter]

info@caldera.com
Copyright © 1991, 1997 Caldera, Inc. All rights reserved.